Zentyal 3.5 Available for Testing: OpenLDAP Removal Completed

Zentyal Development Team is glad to announce that the next Zentyal Linux Small Business Server release is a step closer: All the Zentyal 3.5 feature development is now finished and we encourage you to start testing the Daily Builds. From now, the team will mainly focus on bugfixing, QA, polishing details and working on migration path from Zentyal Server 3.4 to 3.5. The highlights of this new release – that aims at offering a drop-in replacement for Windows® Small Business Server and Microsoft® Exchange Server – will be:

  • Removal of synchronization with OpenLDAP
  • Distribution upgrade from Ubuntu Server 13.10 to Ubuntu Server 14.04 LTS
  • Support for Microsoft® Outlook 2010
  • Support for ActiveSync®
  • Automatic Inbox refresh

Zentyal Server 3.5 will be published on the 1st of July. The release date has been delayed for two weeks from the initially estimated date due to the effort the OpenLDAP removal has caused and to respect the code freeze period and QA requirements. The OpenLDAP removal has also made us to take the decision to move two highly OpenLDAP-related modules (usercorner and captiveportal together with bwmonitor) to the contrib repository, in order to guarantee a stable release.

Due to number of questions arisen regarding the OpenLDAP removal, it is important to note that this does not mean that we are removing the LDAP integration. Until now Zentyal Server has had two LDAP implementations (OpenLDAP and Samba4): We are removing the OpenLDAP implementation because having two LDAP servers is causing lots of synchronization issues and this allows us to simplify the server architecture significantly. When this is done, Zentyal Server will still offer an implementation of the LDAP protocol.

So, it is testing time! Test a fresh install of the latest Zentyal 3.5 Daily Build ISO and start reporting any problems you encounter through the Tracker to ensure they are fixed before the final release. Please keep in mind that Daily Builds are not intended for production environments and upgrades from a previous 3.5 installation are not guaranteed.

Happy Testing!

Leave a Reply

Your email address will not be published. Required fields are marked *


Customers
Trusting Zentyal

simply elekta